# openssl-encrypt accepts refresh tokens as URL query parameters causing token leakage

Advisory record · `GHSA-4rh7-jwg9-m28m`

- **Identifiers:** `GHSA-4rh7-jwg9-m28m` · `CVE-2026-74880` · `PYSEC-2026-3759`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-598](https://cwe.mitre.org/data/definitions/598.html)
- **Tags:** [CWE-598](https://agentprime.io/advisories/tag/cwe-598.md)
- **Published:** 1 Apr 2026
- **Updated:** 2 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Apr 2026, 21:12 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `openssl-encrypt` (PyPI): affected `<1.4.0`; fixed in `1.4.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of openssl-encrypt before 1.4.0 accept refresh tokens as URL query parameters on the keyserver and telemetry server routes, so tokens can end up in server access logs, proxy or CDN logs, browser history, HTTP Referer headers, and network monitoring tools. The source does not say what an attacker must already have access to in order to read those logs. Upgrade to openssl-encrypt 1.4.0, which moves the refresh token into the POST request body.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:38 UTC: First seen by agentprime
- 31 Oct 2026, 14:38 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4rh7-jwg9-m28m)

## Sources

- [GitHub Advisory Database: GHSA-4rh7-jwg9-m28m](https://github.com/advisories/GHSA-4rh7-jwg9-m28m)
- [OSV: GHSA-4rh7-jwg9-m28m](https://osv.dev/vulnerability/GHSA-4rh7-jwg9-m28m)
- <https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-4rh7-jwg9-m28m>
- <https://github.com/jahlives/openssl_encrypt/commit/4b2adb05cde8a7ee03cdd271755da3b377c68011>
- <https://github.com/jahlives/openssl_encrypt>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4rh7-jwg9-m28m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4rh7-jwg9-m28m/>. Everything for agents: <https://agentprime.io/llms.txt>.
