# PraisonAI: Prompt-injection defense blocks only when 3+ detector families fire simultaneously; realistic single-vector injections pass through unblocked

Advisory record · `GHSA-4r3p-w3mc-5v34`

- **Identifiers:** `GHSA-4r3p-w3mc-5v34` · `CVE-2026-60086` · `PYSEC-2026-4248`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-693](https://cwe.mitre.org/data/definitions/693.html)
- **Tags:** [CWE-693](https://agentprime.io/advisories/tag/cwe-693.md)
- **Published:** 8 Oct 2026
- **Updated:** 15 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Oct 2026, 19:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `praisonai` (PyPI): affected `<4.6.78`; fixed in `4.6.78`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> PraisonAI versions before 4.6.78 have a prompt-injection defense, enabled through enable_injection_defense(), that blocks only when three or more detector families match at once. Realistic single- or double-vector injections are rated HIGH and pass through unmodified, so an attacker who can supply input to the model can reach it and its tools. Upgrade praisonai to version 4.6.78 or later, which is the listed fix.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0027, the 18th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4r3p-w3mc-5v34)

## Sources

- [GitHub Advisory Database: GHSA-4r3p-w3mc-5v34](https://github.com/advisories/GHSA-4r3p-w3mc-5v34)
- [OSV: GHSA-4r3p-w3mc-5v34](https://osv.dev/vulnerability/GHSA-4r3p-w3mc-5v34)
- <https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-4r3p-w3mc-5v34>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-60086>
- <https://github.com/MervinPraison/PraisonAI>
- <https://www.vulncheck.com/advisories/praisonai-before-prompt-injection-defense-bypass>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4r3p-w3mc-5v34>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4r3p-w3mc-5v34/>. Everything for agents: <https://agentprime.io/llms.txt>.
