# HTTP Request Smuggling: Content-Length Sent Twice in Waitress

Advisory record · `GHSA-4ppp-gpcr-7qf6`

- **Identifiers:** `GHSA-4ppp-gpcr-7qf6` · `CVE-2019-16792` · `GHSA-j7j6-7hfx-5522` · `PYSEC-2020-178`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 20 Dec 2019
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Dec 2019, 23:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `waitress` (PyPI): affected `<1.4.0`; fixed in `1.4.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.020, the 80th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Dec 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4ppp-gpcr-7qf6](https://github.com/advisories/GHSA-4ppp-gpcr-7qf6)
- [OSV: GHSA-4ppp-gpcr-7qf6](https://osv.dev/vulnerability/GHSA-4ppp-gpcr-7qf6)
- <https://github.com/Pylons/waitress/security/advisories/GHSA-4ppp-gpcr-7qf6>
- <https://nvd.nist.gov/vuln/detail/CVE-2019-16792>
- <https://github.com/Pylons/waitress/commit/575994cd42e83fd772a5f7ec98b2c56751bd3f65>
- <https://docs.pylonsproject.org/projects/waitress/en/latest/#security-fixes>
- <https://github.com/Pylons/waitress>
- <https://github.com/pypa/advisory-database/tree/main/vulns/waitress/PYSEC-2020-178.yaml>
- <https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html>
- <https://www.oracle.com/security-alerts/cpuapr2022.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4ppp-gpcr-7qf6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4ppp-gpcr-7qf6/>. Everything for agents: <https://agentprime.io/llms.txt>.
