# MessagePack::Buffer#clear Use-After-Free that Enables Cross-Buffer Disclosure

Advisory record · `GHSA-4mrv-5p47-p938`

- **Identifiers:** `GHSA-4mrv-5p47-p938` · `CVE-2026-54522`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-416](https://cwe.mitre.org/data/definitions/416.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 30 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Jul 2026, 16:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `msgpack` (RubyGems): affected `<1.8.2`; fixed in `1.8.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0023, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4mrv-5p47-p938)

## Sources

- [GitHub Advisory Database: GHSA-4mrv-5p47-p938](https://github.com/advisories/GHSA-4mrv-5p47-p938)
- [OSV: GHSA-4mrv-5p47-p938](https://osv.dev/vulnerability/GHSA-4mrv-5p47-p938)
- <https://github.com/msgpack/msgpack-ruby/security/advisories/GHSA-4mrv-5p47-p938>
- <https://github.com/msgpack/msgpack-ruby/commit/5627d71606b565641d2dd501b82aae862f4abe90>
- <https://github.com/msgpack/msgpack-ruby>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/msgpack/CVE-2026-54522.yml>
- <https://www.cve.org/CVERecord/SearchResults?query=CVE-2026-54522>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4mrv-5p47-p938>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4mrv-5p47-p938/>. Everything for agents: <https://agentprime.io/llms.txt>.
