# fastify vulnerable to Denial of Service via unhandled exception on HTTP/2 trailer responses

Advisory record · `GHSA-4mh8-r7rc-xpvc`

- **Identifiers:** `GHSA-4mh8-r7rc-xpvc` · `CVE-2026-92081`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 30 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Sept 2026, 23:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fastify` (npm): affected `<5.12.5`; fixed in `5.12.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4mh8-r7rc-xpvc)

## Sources

- [GitHub Advisory Database: GHSA-4mh8-r7rc-xpvc](https://github.com/advisories/GHSA-4mh8-r7rc-xpvc)
- [OSV: GHSA-4mh8-r7rc-xpvc](https://osv.dev/vulnerability/GHSA-4mh8-r7rc-xpvc)
- <https://github.com/fastify/fastify/security/advisories/GHSA-4mh8-r7rc-xpvc>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-92081>
- <https://github.com/fastify/fastify/issues/6574>
- <https://github.com/fastify/fastify/commit/ad06a4c3fe8a944a904f38068249b18b8f552e90>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/fastify/fastify>
- <https://github.com/fastify/fastify/releases/tag/v5.12.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4mh8-r7rc-xpvc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4mh8-r7rc-xpvc/>. Everything for agents: <https://agentprime.io/llms.txt>.
