# Incus Vulnerable to Panic via Snapshot Bounds Check

Advisory record · `GHSA-4m88-wxj4-9qj6`

- **Identifiers:** `GHSA-4m88-wxj4-9qj6` · `CVE-2026-40251` · `GO-2026-5127`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-125](https://cwe.mitre.org/data/definitions/125.html) · [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 4 May 2026
- **Updated:** 25 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 May 2026, 19:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/lxc/incus/v6/cmd/incusd` (Go): affected `<7.0.0`; fixed in `7.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Incus, the Go package github.com/lxc/incus/v6/cmd/incusd, is affected in versions before 7.0.0. An authenticated user with access to the storage volume feature can submit a crafted backup archive whose snapshot metadata is empty or truncated, causing an out-of-bounds panic in the restore and migration paths that crashes the daemon. Repeated exploitation can keep Incus offline. Upgrade to version 7.0.0 or later.

Written 7 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:07 UTC: First seen by agentprime
- 31 Oct 2026, 15:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4m88-wxj4-9qj6)

## Sources

- [GitHub Advisory Database: GHSA-4m88-wxj4-9qj6](https://github.com/advisories/GHSA-4m88-wxj4-9qj6)
- [OSV: GHSA-4m88-wxj4-9qj6](https://osv.dev/vulnerability/GHSA-4m88-wxj4-9qj6)
- <https://github.com/lxc/incus/security/advisories/GHSA-4m88-wxj4-9qj6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-40251>
- <https://github.com/lxc/incus>
- <https://github.com/lxc/incus/blob/v6.22.0/internal/server/storage/backend.go>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4m88-wxj4-9qj6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4m88-wxj4-9qj6/>. Everything for agents: <https://agentprime.io/llms.txt>.
