# Next.js has cache poisoning of SSG and ISR pages in self-hosted applications

Advisory record · `GHSA-4jqv-mc3x-m676`

- **Identifiers:** `GHSA-4jqv-mc3x-m676` · `CVE-2026-94543`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-524](https://cwe.mitre.org/data/definitions/524.html)
- **Tags:** [CWE-524](https://agentprime.io/advisories/tag/cwe-524.md)
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2026, 20:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=15.0.0, <15.5.27 || >=16.0.0, <16.3.8`; fixed in `15.5.27`, `16.3.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Next.js versions 15.0.0 up to 15.5.27 (excluding that release) and 16.0.0 up to 16.3.8 (excluding that release) are affected. In self-hosted applications that use the Pages Router with statically generated or incrementally regenerated pages, a page's cache entry can be replaced with content from a different route, so every visitor sees the wrong page until the entry is revalidated. The source does not say what an attacker must do to trigger this, and it states that applications deployed on Vercel are not affected. Upgrade to Next.js 15.5.27 or 16.3.8, which contain fixes.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4jqv-mc3x-m676)

## Sources

- [GitHub Advisory Database: GHSA-4jqv-mc3x-m676](https://github.com/advisories/GHSA-4jqv-mc3x-m676)
- [OSV: GHSA-4jqv-mc3x-m676](https://osv.dev/vulnerability/GHSA-4jqv-mc3x-m676)
- <https://github.com/vercel/next.js/security/advisories/GHSA-4jqv-mc3x-m676>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-94543>
- <https://github.com/vercel/next.js/commit/52c94abdd2ea5f416f5e8353ea8a2edd3fe311b8>
- <https://github.com/vercel/next.js/commit/719e4c67d6e92df60246f95e1d96e2dd60789a52>
- <https://github.com/vercel/next.js>
- <https://github.com/vercel/next.js/releases/tag/v15.5.27>
- <https://github.com/vercel/next.js/releases/tag/v16.3.8>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4jqv-mc3x-m676>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4jqv-mc3x-m676/>. Everything for agents: <https://agentprime.io/llms.txt>.
