# LangGraph JavaScript custom authentication may permit cross-user Store access

Advisory record · `GHSA-4hm6-w6qq-w73v`

- **Identifiers:** `GHSA-4hm6-w6qq-w73v` · `CVE-2026-118668`
- **State:** Confirmed
- **Severity:** CVSS 8.6 High
- **Critical:** No
- **Weakness (CWE):** [CWE-639](https://cwe.mitre.org/data/definitions/639.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 21:09 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `langgraph-api` (PyPI): affected `>=0.1.2, <0.15.0`; fixed in `0.15.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.6 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4hm6-w6qq-w73v)

## Sources

- [GitHub Advisory Database: GHSA-4hm6-w6qq-w73v](https://github.com/advisories/GHSA-4hm6-w6qq-w73v)
- [OSV: GHSA-4hm6-w6qq-w73v](https://osv.dev/vulnerability/GHSA-4hm6-w6qq-w73v)
- <https://github.com/langchain-ai/langgraph/security/advisories/GHSA-4hm6-w6qq-w73v>
- <https://github.com/langchain-ai/langgraph>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4hm6-w6qq-w73v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4hm6-w6qq-w73v/>. Everything for agents: <https://agentprime.io/llms.txt>.
