# Budibase auth session cookies are set with httpOnly:false — any XSS can lead to full account takeover

Advisory record · `GHSA-4f9j-vr4p-642r`

- **Identifiers:** `GHSA-4f9j-vr4p-642r` · `CVE-2026-42239`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1004](https://cwe.mitre.org/data/definitions/1004.html)
- **Tags:** [CWE-1004](https://agentprime.io/advisories/tag/cwe-1004.md)
- **Published:** 24 Apr 2026
- **Updated:** 11 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Apr 2026, 16:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@budibase/backend-core` (npm): affected `<3.35.10`; fixed in `3.35.10`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Apr 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-4f9j-vr4p-642r](https://github.com/advisories/GHSA-4f9j-vr4p-642r)
- [OSV: GHSA-4f9j-vr4p-642r](https://osv.dev/vulnerability/GHSA-4f9j-vr4p-642r)
- <https://github.com/Budibase/budibase/security/advisories/GHSA-4f9j-vr4p-642r>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42239>
- <https://github.com/Budibase/budibase>
- <https://github.com/Budibase/budibase/releases/tag/3.35.10>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4f9j-vr4p-642r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4f9j-vr4p-642r/>. Everything for agents: <https://agentprime.io/llms.txt>.
