# Langflow: IP Spoofing Bypass via \`X-Forwarded-For\` Allowing Remote Configuration Write

Advisory record · `GHSA-4f6c-2vvp-gw82`

- **Identifiers:** `GHSA-4f6c-2vvp-gw82` · `CVE-2026-105741` · `PYSEC-2026-4229`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-290](https://cwe.mitre.org/data/definitions/290.html) · [CWE-345](https://cwe.mitre.org/data/definitions/345.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md)
- **Published:** 7 Oct 2026
- **Updated:** 15 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2026, 16:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `langflow` (PyPI): affected `>=1.5.0, <1.10.3`; fixed in `1.10.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Langflow versions 1.5.0 up to but not including 1.10.3 are affected. An authenticated remote attacker can send a spoofed X-Forwarded-For header to bypass the local-only restriction on the MCP configuration install endpoint and overwrite a fixed set of IDE/MCP client configuration files on the server, such as the Cursor or Claude Desktop config. Upgrade to Langflow 1.10.3 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 15th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4f6c-2vvp-gw82)

## Sources

- [GitHub Advisory Database: GHSA-4f6c-2vvp-gw82](https://github.com/advisories/GHSA-4f6c-2vvp-gw82)
- [OSV: GHSA-4f6c-2vvp-gw82](https://osv.dev/vulnerability/GHSA-4f6c-2vvp-gw82)
- <https://github.com/langflow-ai/langflow/security/advisories/GHSA-4f6c-2vvp-gw82>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-105741>
- <https://github.com/langflow-ai/langflow/pull/13915>
- <https://github.com/langflow-ai/langflow/commit/1f39a4b9d62c9dfa1b21fa7f85e23a180c351b72>
- <https://github.com/langflow-ai/langflow/commit/94859df33acd70b2a1f816e26d68f5e89a7e5639>
- <https://github.com/langflow-ai/langflow>
- <https://github.com/langflow-ai/langflow/releases/tag/v1.10.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4f6c-2vvp-gw82>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4f6c-2vvp-gw82/>. Everything for agents: <https://agentprime.io/llms.txt>.
