# Excessive Iteration in gRPC

Advisory record · `GHSA-496j-2rq6-j6cc`

- **Identifiers:** `GHSA-496j-2rq6-j6cc` · `CVE-2023-33953` · `PYSEC-2026-1424`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html) · [CWE-789](https://cwe.mitre.org/data/definitions/789.html) · [CWE-834](https://cwe.mitre.org/data/definitions/834.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 9 Aug 2023
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Aug 2023, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `grpcio` (PyPI): affected `<1.53.2 || >=1.54.0, <1.54.3 || >=1.55.0, <1.55.2 || >=1.56.0, <1.56.2`; fixed in `1.53.2`, `1.54.3`, `1.55.2`, `1.56.2`
- `grpc` (RubyGems): affected `<1.53.2 || >=1.54.0, <1.54.3 || >=1.55.0, <1.55.2 || >=1.56.0, <1.56.2`; fixed in `1.53.2`, `1.54.3`, `1.55.2`, `1.56.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (Google)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0048, the 41st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 9 Aug 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-496j-2rq6-j6cc](https://github.com/advisories/GHSA-496j-2rq6-j6cc)
- [OSV: GHSA-496j-2rq6-j6cc](https://osv.dev/vulnerability/GHSA-496j-2rq6-j6cc)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-33953>
- <https://cloud.google.com/support/bulletins#gcp-2023-022>
- <https://github.com/advisories/GHSA-496j-2rq6-j6cc>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-33953.yml>
- <https://security.snyk.io/vuln/SNYK-RUBY-GRPC-5834442>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-496j-2rq6-j6cc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-496j-2rq6-j6cc/>. Everything for agents: <https://agentprime.io/llms.txt>.
