# imgproxy has out-of-bounds heap read/write in ICO loader BMP header reconstruction that allows unauthenticated remote worker crash

Advisory record · `GHSA-494m-4556-wf5p`

- **Identifiers:** `GHSA-494m-4556-wf5p` · `GO-2026-6895`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-125](https://cwe.mitre.org/data/definitions/125.html) · [CWE-787](https://cwe.mitre.org/data/definitions/787.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 30 Oct 2026
- **Updated:** 5 Nov 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Oct 2026, 22:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/imgproxy/imgproxy/v3` (Go): affected `>=3.3.0, <4.0.17`; fixed in `4.0.17`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Affected: the Go package github.com/imgproxy/imgproxy/v3, versions 3.3.0 up to 4.0.17 (fixed in 4.0.17). An out-of-bounds heap write in the ICO image loader lets an attacker who supplies a crafted ICO image crash the imgproxy worker process, causing denial of service. Upgrade to version 4.0.17 or later; the source lists no workaround.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-494m-4556-wf5p)

## Sources

- [GitHub Advisory Database: GHSA-494m-4556-wf5p](https://github.com/advisories/GHSA-494m-4556-wf5p)
- [OSV: GHSA-494m-4556-wf5p](https://osv.dev/vulnerability/GHSA-494m-4556-wf5p)
- <https://github.com/imgproxy/imgproxy/security/advisories/GHSA-494m-4556-wf5p>
- <https://github.com/imgproxy/imgproxy/pull/1726>
- <https://github.com/imgproxy/imgproxy/commit/39fd9e844a8a46084161502e993d5a3c16ccf28d>
- <https://github.com/imgproxy/imgproxy>
- <https://github.com/imgproxy/imgproxy/releases/tag/v4.0.17>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-494m-4556-wf5p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-494m-4556-wf5p/>. Everything for agents: <https://agentprime.io/llms.txt>.
