# Pterodactyl Wings vulnerable to improper isolation of server file access

Advisory record · `GHSA-494h-9924-xww9`

- **Identifiers:** `GHSA-494h-9924-xww9` · `CVE-2024-27102` · `GO-2024-2642`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-362](https://cwe.mitre.org/data/definitions/362.html) · [CWE-363](https://cwe.mitre.org/data/definitions/363.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [Race condition](https://agentprime.io/advisories/tag/race-condition.md) · [CWE-363](https://agentprime.io/advisories/tag/cwe-363.md)
- **Published:** 15 Mar 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Mar 2024, 16:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/pterodactyl/wings` (Go): affected `<1.11.9`; fixed in `1.11.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pterodactyl Wings versions before 1.11.9 are vulnerable to improper isolation of server file access, which can let an attacker read files and directories outside a server's base directory on the host system. An attacker must first have a server allocated and controlled by Wings. Upgrade to Wings 1.11.9 or newer; the source lists no workarounds.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-494h-9924-xww9)

## Sources

- [GitHub Advisory Database: GHSA-494h-9924-xww9](https://github.com/advisories/GHSA-494h-9924-xww9)
- [OSV: GHSA-494h-9924-xww9](https://osv.dev/vulnerability/GHSA-494h-9924-xww9)
- <https://github.com/pterodactyl/wings/security/advisories/GHSA-494h-9924-xww9>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-27102>
- <https://github.com/pterodactyl/wings/commit/d1c0ca526007113a0f74f56eba99511b4e989287>
- <https://github.com/pterodactyl/wings>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-494h-9924-xww9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-494h-9924-xww9/>. Everything for agents: <https://agentprime.io/llms.txt>.
