# Puma with proxy which forwards LF characters as line endings could allow HTTP request smuggling

Advisory record · `GHSA-48w2-rm65-62xx`

- **Identifiers:** `GHSA-48w2-rm65-62xx` · `CVE-2021-41136`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 12 Oct 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Oct 2021, 17:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `puma` (RubyGems): affected `>=5.0.0, <5.5.1 || <4.3.9`; fixed in `5.5.1`, `4.3.9`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 68th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 12 Oct 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-48w2-rm65-62xx](https://github.com/advisories/GHSA-48w2-rm65-62xx)
- [OSV: GHSA-48w2-rm65-62xx](https://osv.dev/vulnerability/GHSA-48w2-rm65-62xx)
- <https://github.com/puma/puma/security/advisories/GHSA-48w2-rm65-62xx>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-41136>
- <https://github.com/puma/puma/commit/436c71807f00e07070902a03f79fd3e130eb6b18>
- <https://github.com/puma/puma/commit/acdc3ae571dfae0e045cf09a295280127db65c7f>
- <https://github.com/puma/puma/commit/fb6ad8f8013ab5cdbb2f444cbfabd0b4fde71139>
- <https://github.com/puma/puma>
- <https://github.com/puma/puma/releases/tag/v4.3.9>
- <https://github.com/puma/puma/releases/tag/v5.5.1>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2021-41136.yml>
- <https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html>
- <https://security.gentoo.org/glsa/202208-28>
- <https://www.debian.org/security/2022/dsa-5146>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-48w2-rm65-62xx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-48w2-rm65-62xx/>. Everything for agents: <https://agentprime.io/llms.txt>.
