# Inefficient Regular Expression Complexity in Loofah

Advisory record · `GHSA-486f-hjj9-9vhh`

- **Identifiers:** `GHSA-486f-hjj9-9vhh` · `CVE-2022-23514`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1333](https://cwe.mitre.org/data/definitions/1333.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 13 Dec 2022
- **Updated:** 4 Nov 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 13 Dec 2022, 17:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `loofah` (RubyGems): affected `<2.19.1`; fixed in `2.19.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 78th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 13 Dec 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-486f-hjj9-9vhh](https://github.com/advisories/GHSA-486f-hjj9-9vhh)
- [OSV: GHSA-486f-hjj9-9vhh](https://osv.dev/vulnerability/GHSA-486f-hjj9-9vhh)
- <https://github.com/flavorjones/loofah/security/advisories/GHSA-486f-hjj9-9vhh>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-23514>
- <https://github.com/flavorjones/loofah/commit/a6e0a1ab90675a17b1b2be189129d94139e4b143>
- <https://hackerone.com/reports/1684163>
- <https://github.com/flavorjones/loofah>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/loofah/CVE-2022-23514.yml>
- <https://lists.debian.org/debian-lts-announce/2023/09/msg00011.html>
- <https://lists.debian.org/debian-lts-announce/2024/09/msg00044.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-486f-hjj9-9vhh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-486f-hjj9-9vhh/>. Everything for agents: <https://agentprime.io/llms.txt>.
