# Unbounded buffer accumulation in multipart header parsing causes denial of service in plug

Advisory record · `GHSA-468c-vq7p-gh64`

- **Identifiers:** `GHSA-468c-vq7p-gh64` · `CVE-2026-8468` · `EEF-CVE-2026-8468`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 14 May 2026
- **Updated:** 8 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 May 2026, 10:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `plug` (Hex): affected `>=1.4.0, <1.15.4 || >=1.16.0, <1.16.3 || >=1.17.0, <1.17.1 || >=1.18.0, <1.18.2 || >=1.19.0, <1.19.2`; fixed in `1.15.4`, `1.16.3`, `1.17.1`, `1.18.2`, `1.19.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (EEF)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:25 UTC: First seen by agentprime
- 31 Oct 2026, 15:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/EEF-CVE-2026-8468)

## Sources

- [GitHub Advisory Database: GHSA-468c-vq7p-gh64](https://github.com/advisories/GHSA-468c-vq7p-gh64)
- [OSV: GHSA-468c-vq7p-gh64](https://osv.dev/vulnerability/GHSA-468c-vq7p-gh64)
- <https://github.com/elixir-plug/plug/security/advisories/GHSA-468c-vq7p-gh64>
- <https://cna.erlef.org/cves/CVE-2026-8468.html>
- <https://cna.erlef.org/cves/CVE-2026-8466.html>
- <https://github.com/elixir-plug/plug/commit/2cb7958d33030aa826b0c7404375844d4593d43a>
- <https://github.com/elixir-plug/plug/commit/aa69c5ece99c40ded88b8c6581ecc86664b0b734>
- <https://github.com/elixir-plug/plug/commit/d5dfffe25e975585227b1b85d247b0d14164bc45>
- <https://github.com/elixir-plug/plug/commit/df812a1527bae9e941965e897308a2b8bbf83a94>
- <https://github.com/elixir-plug/plug/commit/33858427c7f2737d560a2e40a0c9a9270d77d1d7>
- <https://hex.pm/packages/plug>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-468c-vq7p-gh64>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-468c-vq7p-gh64/>. Everything for agents: <https://agentprime.io/llms.txt>.
