# RabbitMQ amqp091-go: Connection Configuration Overwrite via Unsanitized TLS Path Parameter Injection

Advisory record · `GHSA-465g-fh3v-9jw4`

- **Identifiers:** `GHSA-465g-fh3v-9jw4` · `CVE-2026-77404` · `GO-2026-6493`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 17 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Sept 2026, 17:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/rabbitmq/amqp091-go` (Go): affected `<1.13.0`; fixed in `1.13.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-465g-fh3v-9jw4 affects the Go package github.com/rabbitmq/amqp091-go before 1.13.0. TLS file paths are appended to connection URI query strings without escaping, so paths containing & or = can inject extra parameters that overwrite settings when the URI is re-parsed. An attacker who controls part of a TLS file path that the application uses could alter connection settings or load different TLS files. Upgrade to version 1.13.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0010, the 1st percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-465g-fh3v-9jw4)

## Sources

- [GitHub Advisory Database: GHSA-465g-fh3v-9jw4](https://github.com/advisories/GHSA-465g-fh3v-9jw4)
- [OSV: GHSA-465g-fh3v-9jw4](https://osv.dev/vulnerability/GHSA-465g-fh3v-9jw4)
- <https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-465g-fh3v-9jw4>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-77404>
- <https://github.com/rabbitmq/amqp091-go/pull/352>
- <https://github.com/rabbitmq/amqp091-go/commit/743d488e46955fe7ffc55506fe2c401d01216783>
- <https://github.com/rabbitmq/amqp091-go>
- <https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-465g-fh3v-9jw4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-465g-fh3v-9jw4/>. Everything for agents: <https://agentprime.io/llms.txt>.
