# XWiki Platform Live Data Live Table Connector has privilege escalation from edit to script right through Live Data editing

Advisory record · `GHSA-45ph-gxxr-gwgw`

- **Identifiers:** `GHSA-45ph-gxxr-gwgw` · `CVE-2026-53966`
- **State:** Confirmed
- **Severity:** CVSS 7.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Aug 2026, 19:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.xwiki.platform:xwiki-platform-livedata-livetable` (Maven): affected `>=13.4-rc-1, <16.10.17 || >=17.0.0-rc-1, <17.4.10 || >=17.5.0-rc-1, <17.10.4 || >=18.0.0-rc-1, <18.1.0-rc-1`; fixed in `16.10.17`, `17.4.10`, `17.10.4`, `18.1.0-rc-1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The xwiki-platform-livedata-livetable Maven package, which is part of XWiki Platform's Live Data Live Table connector, is vulnerable in versions before 16.10.17, from 17.0.0-rc-1 before 17.4.10, from 17.5.0-rc-1 before 17.10.4, and from 18.0.0-rc-1 before 18.1.0-rc-1. Any user who can edit a page can use the Live Data edit REST API to change that page's rights and gain script right, allowing them to run Velocity scripts and send unfiltered HTML and JavaScript to clients. Upgrade to 16.10.17, 17.4.10, 17.10.4, or 18.1.0-rc-1 or later; no workaround other than upgrading is known.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.1 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0077, the 55th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-45ph-gxxr-gwgw)

## Sources

- [GitHub Advisory Database: GHSA-45ph-gxxr-gwgw](https://github.com/advisories/GHSA-45ph-gxxr-gwgw)
- [OSV: GHSA-45ph-gxxr-gwgw](https://osv.dev/vulnerability/GHSA-45ph-gxxr-gwgw)
- <https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-45ph-gxxr-gwgw>
- <https://github.com/xwiki/xwiki-platform/commit/448b0f074cc6711410eb2647c4740454c92d1626>
- <https://github.com/xwiki/xwiki-platform>
- <https://jira.xwiki.org/browse/XWIKI-23986>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-45ph-gxxr-gwgw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-45ph-gxxr-gwgw/>. Everything for agents: <https://agentprime.io/llms.txt>.
