# aiohttp.web.Application vulnerable to HTTP request smuggling via llhttp HTTP request parser

Advisory record · `GHSA-45c4-8wx5-qw6w`

- **Identifiers:** `GHSA-45c4-8wx5-qw6w` · `CVE-2023-37276` · `PYSEC-2023-120`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 20 Jul 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Jul 2023, 14:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `aiohttp` (PyPI): affected `<3.8.5`; fixed in `3.8.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The aiohttp package before 3.8.5 is vulnerable to HTTP request smuggling when used as an HTTP server, because its bundled llhttp request parser misreads certain header values. A remote attacker can send a crafted HTTP request to cause this smuggling. Upgrade aiohttp to version 3.8.5 or later; if that is not possible, reinstall aiohttp with the AIOHTTP_NO_EXTENSIONS=1 environment variable to use the pure Python parser instead.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 71st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:37 UTC: First seen by agentprime
- 31 Oct 2026, 14:37 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-45c4-8wx5-qw6w)

## Sources

- [GitHub Advisory Database: GHSA-45c4-8wx5-qw6w](https://github.com/advisories/GHSA-45c4-8wx5-qw6w)
- [OSV: GHSA-45c4-8wx5-qw6w](https://osv.dev/vulnerability/GHSA-45c4-8wx5-qw6w)
- <https://github.com/aio-libs/aiohttp/security/advisories/GHSA-45c4-8wx5-qw6w>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-37276>
- <https://github.com/aio-libs/aiohttp/commit/9337fb3f2ab2b5f38d7e98a194bde6f7e3d16c40>
- <https://github.com/aio-libs/aiohttp/commit/9c13a52c21c23dfdb49ed89418d28a5b116d0681>
- <https://hackerone.com/reports/2001873>
- <https://github.com/aio-libs/aiohttp>
- <https://github.com/aio-libs/aiohttp/blob/v3.8.4/.gitmodules>
- <https://github.com/pypa/advisory-database/tree/main/vulns/aiohttp/PYSEC-2023-120.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-45c4-8wx5-qw6w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-45c4-8wx5-qw6w/>. Everything for agents: <https://agentprime.io/llms.txt>.
