# Pillow: P;2L and P;4L decoders may read 1 to 3 bytes past the passed buffer size

Advisory record · `GHSA-4558-3h8r-v8xp`

- **Identifiers:** `GHSA-4558-3h8r-v8xp` · `BIT-pillow-2026-112394` · `CVE-2026-112394` · `PYSEC-2026-4327`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-126](https://cwe.mitre.org/data/definitions/126.html)
- **Tags:** [CWE-126](https://agentprime.io/advisories/tag/cwe-126.md)
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Oct 2026, 20:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pillow` (PyPI): affected `<13.0.0`; fixed in `13.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pillow versions before 13.0.0 have a bug in the P;2L and P;4L decoders, where the decoder's size check and the plane unpackers disagree about how many bytes a line needs. Using Image.frombytes() or Image.frombuffer() with particular width and height values, an attacker who can supply the image data can cause up to 1 or 3 bytes of memory past the caller's buffer to be read into the last decoded rows, and a crash is possible if the read reaches unmapped memory. Upgrade to Pillow 13.0.0 or later, which contains the fix.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-4558-3h8r-v8xp)

## Sources

- [GitHub Advisory Database: GHSA-4558-3h8r-v8xp](https://github.com/advisories/GHSA-4558-3h8r-v8xp)
- [OSV: GHSA-4558-3h8r-v8xp](https://osv.dev/vulnerability/GHSA-4558-3h8r-v8xp)
- <https://github.com/python-pillow/Pillow/security/advisories/GHSA-4558-3h8r-v8xp>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-112394>
- <https://github.com/python-pillow/Pillow/pull/9723>
- <https://github.com/python-pillow/Pillow/commit/392ee6f0d19a4adb766a63e9a99f3c28193b8d31>
- <https://github.com/python-pillow/Pillow>
- <https://github.com/python-pillow/Pillow/releases/tag/13.0.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-4558-3h8r-v8xp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-4558-3h8r-v8xp/>. Everything for agents: <https://agentprime.io/llms.txt>.
