# Pillow buffer overflow vulnerability

Advisory record · `GHSA-44wm-f244-xhp3`

- **Identifiers:** `GHSA-44wm-f244-xhp3` · `BIT-pillow-2024-28219` · `CVE-2024-28219` · `PYSEC-2026-1793`
- **State:** Confirmed
- **Severity:** CVSS 6.7 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-120](https://cwe.mitre.org/data/definitions/120.html) · [CWE-676](https://cwe.mitre.org/data/definitions/676.html) · [CWE-680](https://cwe.mitre.org/data/definitions/680.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-676](https://agentprime.io/advisories/tag/cwe-676.md)
- **Published:** 3 Apr 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Apr 2024, 03:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pillow` (PyPI): affected `<10.3.0`; fixed in `10.3.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pillow versions before 10.3.0 are vulnerable to a buffer overflow in \_imagingcms.c, where strcpy is used instead of strncpy. The source gives few details about how an attacker would trigger it or what they could achieve. Upgrade to Pillow 10.3.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.7 Medium, CVSS 3.1: `CVSS:3.1/AC:H/AV:L/A:H/C:H/I:H/PR:L/S:U/UI:R`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0100, the 62nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-44wm-f244-xhp3)

## Sources

- [GitHub Advisory Database: GHSA-44wm-f244-xhp3](https://github.com/advisories/GHSA-44wm-f244-xhp3)
- [OSV: GHSA-44wm-f244-xhp3](https://osv.dev/vulnerability/GHSA-44wm-f244-xhp3)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-28219>
- <https://github.com/python-pillow/Pillow/commit/2a93aba5cfcf6e241ab4f9392c13e3b74032c061>
- <https://github.com/python-pillow/Pillow>
- <https://lists.debian.org/debian-lts-announce/2024/04/msg00008.html>
- <https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4XLPUT3VK4GQ6EVY525TT2QNUIXNRU5M>
- <https://pillow.readthedocs.io/en/stable/releasenotes/10.3.0.html#security>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-44wm-f244-xhp3>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-44wm-f244-xhp3/>. Everything for agents: <https://agentprime.io/llms.txt>.
