# @better-auth/drizzle-adapter: Concurrent requests can exceed rate limits on PostgreSQL

Advisory record · `GHSA-44jh-23m7-hpcf`

- **Identifiers:** `GHSA-44jh-23m7-hpcf` · `CVE-2026-110861`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-307](https://cwe.mitre.org/data/definitions/307.html) · [CWE-362](https://cwe.mitre.org/data/definitions/362.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [Race condition](https://agentprime.io/advisories/tag/race-condition.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 15:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@better-auth/drizzle-adapter` (npm): affected `>=1.6.17, <1.7.7`; fixed in `1.7.7`
- `@better-auth/kysely-adapter` (npm): affected `>=1.6.17, <1.7.0`; fixed in `1.7.0`
- `better-auth` (npm): affected `>=1.6.17, <1.7.7`; fixed in `1.7.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-44jh-23m7-hpcf)

## Sources

- [GitHub Advisory Database: GHSA-44jh-23m7-hpcf](https://github.com/advisories/GHSA-44jh-23m7-hpcf)
- [OSV: GHSA-44jh-23m7-hpcf](https://osv.dev/vulnerability/GHSA-44jh-23m7-hpcf)
- <https://github.com/better-auth/better-auth/security/advisories/GHSA-44jh-23m7-hpcf>
- <https://github.com/better-auth/better-auth/pull/11331>
- <https://github.com/better-auth/better-auth/commit/35d7cd389220f99cfc98ac699e6a42b48313a740>
- <https://github.com/better-auth/better-auth>
- <https://github.com/better-auth/better-auth/releases/tag/v1.7.7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-44jh-23m7-hpcf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-44jh-23m7-hpcf/>. Everything for agents: <https://agentprime.io/llms.txt>.
