# Weblate is a web based localization tool. An open redirect exists in versions 5.13.2 and below via the redir parameter on .within.website when Weblate is configured with Anubis and REDIRECT_DOMAINS...

Advisory record · `GHSA-3xhv-r4gx-xw99`

- **Identifiers:** `GHSA-3xhv-r4gx-xw99` · `CVE-2025-61587` · `PYSEC-2025-269`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-601](https://cwe.mitre.org/data/definitions/601.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Open redirect](https://agentprime.io/advisories/tag/open-redirect.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 1 Oct 2025
- **Updated:** 13 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Oct 2025, 22:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `weblate` (PyPI): affected `<5.13.3`; fixed in `5.13.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Weblate versions up to 5.13.2 are vulnerable to an open redirect through the redir parameter on the .within.website path when Weblate is configured with Anubis and REDIRECT_DOMAINS is not set. An attacker can use a crafted link on the legitimate domain to send a victim to an attacker-controlled site, including one serving a malicious file. Upgrade to Weblate 5.13.3, which fixes the issue.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0039, the 33rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:04 UTC: First seen by agentprime
- 31 Oct 2026, 15:04 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2025-269)

## Sources

- [GitHub Advisory Database: GHSA-3xhv-r4gx-xw99](https://github.com/advisories/GHSA-3xhv-r4gx-xw99)
- [OSV: GHSA-3xhv-r4gx-xw99](https://osv.dev/vulnerability/GHSA-3xhv-r4gx-xw99)
- <https://github.com/WeblateOrg/docker/commit/76518342f65b8af8c2b7f7c5d37f84813c1253a1>
- <https://github.com/WeblateOrg/weblate/commit/6b3d73a310279b5630bca8cbd9ea0be28bc67b63>
- <https://github.com/WeblateOrg/weblate/commit/ec3b900f8a52c5c992d9e7014f09397e159ac381>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3xhv-r4gx-xw99>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3xhv-r4gx-xw99/>. Everything for agents: <https://agentprime.io/llms.txt>.
