# Python Cryptography package vulnerable to Bleichenbacher timing oracle attack

Advisory record · `GHSA-3ww4-gg4f-jr7f`

- **Identifiers:** `GHSA-3ww4-gg4f-jr7f` · `CVE-2023-50782` · `PYSEC-2026-1283`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-203](https://cwe.mitre.org/data/definitions/203.html) · [CWE-208](https://cwe.mitre.org/data/definitions/208.html) · [CWE-385](https://cwe.mitre.org/data/definitions/385.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-208](https://agentprime.io/advisories/tag/cwe-208.md) · [CWE-385](https://agentprime.io/advisories/tag/cwe-385.md)
- **Published:** 5 Feb 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Feb 2024, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `cryptography` (PyPI): affected `<42.0.0`; fixed in `42.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The cryptography package for Python is vulnerable in versions before 42.0.0. A remote attacker may be able to exploit a Bleichenbacher-style timing oracle to decrypt captured messages from TLS servers that use RSA key exchanges, exposing confidential data. Upgrade to version 42.0.0 or later. The source gives few details about the exact conditions of the attack.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (redhat)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 66th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:36 UTC: First seen by agentprime
- 31 Oct 2026, 14:36 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3ww4-gg4f-jr7f)

## Sources

- [GitHub Advisory Database: GHSA-3ww4-gg4f-jr7f](https://github.com/advisories/GHSA-3ww4-gg4f-jr7f)
- [OSV: GHSA-3ww4-gg4f-jr7f](https://osv.dev/vulnerability/GHSA-3ww4-gg4f-jr7f)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-50782>
- <https://github.com/pyca/cryptography/issues/9785>
- <https://access.redhat.com/security/cve/CVE-2023-50782>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2254432>
- <https://github.com/pyca/cryptography>
- <https://www.couchbase.com/alerts>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3ww4-gg4f-jr7f>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3ww4-gg4f-jr7f/>. Everything for agents: <https://agentprime.io/llms.txt>.
