# Traefik affected by Go oauth2/jws Improper Validation of Syntactic Correctness of Input vulnerability

Advisory record · `GHSA-3wqc-mwfx-672p`

- **Identifiers:** `GHSA-3wqc-mwfx-672p`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1286](https://cwe.mitre.org/data/definitions/1286.html)
- **Tags:** [CWE-1286](https://agentprime.io/advisories/tag/cwe-1286.md)
- **Published:** 18 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Apr 2025, 19:32 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/traefik/traefik/v3` (Go): affected `<3.3.6 || >=3.4.0-rc1, <3.4.0-rc2`; fixed in `3.3.6`, `3.4.0-rc2`
- `github.com/traefik/traefik/v2` (Go): affected `<2.11.24`; fixed in `2.11.24`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3wqc-mwfx-672p)

## Sources

- [GitHub Advisory Database: GHSA-3wqc-mwfx-672p](https://github.com/advisories/GHSA-3wqc-mwfx-672p)
- [OSV: GHSA-3wqc-mwfx-672p](https://osv.dev/vulnerability/GHSA-3wqc-mwfx-672p)
- <https://github.com/traefik/traefik/security/advisories/GHSA-3wqc-mwfx-672p>
- <https://github.com/traefik/traefik>
- <https://github.com/traefik/traefik/releases/tag/v2.11.24>
- <https://github.com/traefik/traefik/releases/tag/v3.3.6>
- <https://github.com/traefik/traefik/releases/tag/v3.4.0-rc2>
- <https://security.snyk.io/vuln/SNYK-CHAINGUARDLATEST-TRAEFIK33-9403297>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3wqc-mwfx-672p>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3wqc-mwfx-672p/>. Everything for agents: <https://agentprime.io/llms.txt>.
