# laravel-crud-wizard-free has File Validation Bypass

Advisory record · `GHSA-3wgq-h4fr-cwg5`

- **Identifiers:** `GHSA-3wgq-h4fr-cwg5` · `PKSA-2qkb-kmvg-dvr2`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Weakness (CWE):** [CWE-155](https://cwe.mitre.org/data/definitions/155.html)
- **Tags:** [CWE-155](https://agentprime.io/advisories/tag/cwe-155.md)
- **Published:** 12 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Mar 2025, 15:56 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `macropay-solutions/laravel-crud-wizard-free` (Packagist): affected `<3.4.17`; fixed in `3.4.17`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The macropay-solutions/laravel-crud-wizard-free Packagist package is vulnerable in versions before 3.4.17, and the source describes a file validation bypass. The source gives few details about how the bypass works or what an attacker needs to exploit it, and it does not say what access is required. The fix is to upgrade to version 3.4.17, which the source says addresses illuminate/validation versions 8.0.0 through 11.44.0; the source also gives a workaround for those using illuminate/validation below 11.44.1.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 13:59 UTC: First seen by agentprime
- 31 Oct 2026, 13:59 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3wgq-h4fr-cwg5)

## Sources

- [GitHub Advisory Database: GHSA-3wgq-h4fr-cwg5](https://github.com/advisories/GHSA-3wgq-h4fr-cwg5)
- [OSV: GHSA-3wgq-h4fr-cwg5](https://osv.dev/vulnerability/GHSA-3wgq-h4fr-cwg5)
- <https://github.com/laravel/framework/security/advisories/GHSA-78fx-h6xr-vch4>
- <https://github.com/macropay-solutions/laravel-crud-wizard-free/security/advisories/GHSA-3wgq-h4fr-cwg5>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-27515>
- <https://github.com/macropay-solutions/laravel-crud-wizard-free/commit/5c268cc930ec23a2e6761878cc57c6bd1d1889d2>
- <https://github.com/macropay-solutions/laravel-crud-wizard-free>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3wgq-h4fr-cwg5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3wgq-h4fr-cwg5/>. Everything for agents: <https://agentprime.io/llms.txt>.
