# Wagtail: Improper restriction handling on Pages admin API

Advisory record · `GHSA-3vrh-m9w7-v94f`

- **Identifiers:** `GHSA-3vrh-m9w7-v94f` · `CVE-2026-55468` · `PYSEC-2026-3939`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-280](https://cwe.mitre.org/data/definitions/280.html)
- **Tags:** [CWE-280](https://agentprime.io/advisories/tag/cwe-280.md)
- **Published:** 20 Aug 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Aug 2026, 18:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wagtail` (PyPI): affected `<7.0.9 || >=7.1, <7.3.4 || >=7.4, <7.4.3 || >=8.0rc1, <8.0rc2`; fixed in `7.0.9`, `7.3.4`, `7.4.3`, `8.0rc2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Wagtail versions before 7.0.9, 7.1 through before 7.3.4, 7.4 through before 7.4.3, and 8.0rc1 before 8.0rc2 are affected. The internal Pages admin API returns fields declared in api_fields without access control, so a user with Wagtail admin access can read draft and live page field contents, including custom fields. Upgrade to Wagtail 7.0.9, 7.3.4, 7.4.3, or 8.0rc2. Site owners who cannot upgrade can override the relevant method on PagesAdminAPIViewSet to patch the affected endpoints.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:10 UTC: First seen by agentprime
- 31 Oct 2026, 14:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3vrh-m9w7-v94f)

## Sources

- [GitHub Advisory Database: GHSA-3vrh-m9w7-v94f](https://github.com/advisories/GHSA-3vrh-m9w7-v94f)
- [OSV: GHSA-3vrh-m9w7-v94f](https://osv.dev/vulnerability/GHSA-3vrh-m9w7-v94f)
- <https://github.com/wagtail/wagtail/security/advisories/GHSA-3vrh-m9w7-v94f>
- <https://github.com/wagtail/wagtail>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3vrh-m9w7-v94f>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3vrh-m9w7-v94f/>. Everything for agents: <https://agentprime.io/llms.txt>.
