# Coder accepts an APIKey beyond the linked OIDC expiry if there is no refresh token

Advisory record · `GHSA-3rw9-wmc8-8948`

- **Identifiers:** `GHSA-3rw9-wmc8-8948` · `CVE-2025-71435` · `GO-2025-3921`
- **State:** Confirmed
- **Severity:** CVSS 2.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-324](https://cwe.mitre.org/data/definitions/324.html) · [CWE-613](https://cwe.mitre.org/data/definitions/613.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-324](https://agentprime.io/advisories/tag/cwe-324.md)
- **Published:** 28 Aug 2025
- **Updated:** 18 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Aug 2025, 19:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/coder/coder/v2` (Go): affected `<2.23.0`; fixed in `2.23.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Coder versions before 2.23.0 (github.com/coder/coder/v2) fail to enforce the expiry of an OIDC token when the identity provider returns no refresh token. A user whose OIDC login has expired can keep using the web session, and API requests succeed as long as their APIKey cookie is still valid, which can extend indefinitely if the key is used at least once every 24 hours. Upgrade to Coder 2.23.0 or later. The source gives no workaround.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.3 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0018, the 7th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3rw9-wmc8-8948)

## Sources

- [GitHub Advisory Database: GHSA-3rw9-wmc8-8948](https://github.com/advisories/GHSA-3rw9-wmc8-8948)
- [OSV: GHSA-3rw9-wmc8-8948](https://osv.dev/vulnerability/GHSA-3rw9-wmc8-8948)
- <https://github.com/coder/coder/security/advisories/GHSA-3rw9-wmc8-8948>
- <https://github.com/coder/coder/commit/1a4160803589034ce1518e24a78f232c8d08f996>
- <https://github.com/coder/coder>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3rw9-wmc8-8948>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3rw9-wmc8-8948/>. Everything for agents: <https://agentprime.io/llms.txt>.
