# Unauthenticated Miniflux user can bypass allowed networks check to obtain Prometheus metrics

Advisory record · `GHSA-3qjf-qh38-x73v`

- **Identifiers:** `GHSA-3qjf-qh38-x73v` · `CVE-2023-27591`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-1220](https://cwe.mitre.org/data/definitions/1220.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-1220](https://agentprime.io/advisories/tag/cwe-1220.md)
- **Published:** 2 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Apr 2025, 17:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `miniflux.app/v2` (Go): affected `<2.0.43`; fixed in `2.0.43`
- `miniflux.app` (Go): affected `<=1.0.46`; no fixed version yet

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Miniflux (miniflux.app/v2) versions before 2.0.43 are vulnerable. An unauthenticated remote attacker can reach a publicly exposed instance with the metrics collector enabled and the default allowed networks setting, and retrieve Prometheus metrics. Upgrade to version 2.0.43 or later; alternatively, keep the metrics collector disabled, which is the default. The package miniflux.app at versions 1.0.46 and earlier has no fixed version listed.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0076, the 55th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3qjf-qh38-x73v)

## Sources

- [GitHub Advisory Database: GHSA-3qjf-qh38-x73v](https://github.com/advisories/GHSA-3qjf-qh38-x73v)
- [OSV: GHSA-3qjf-qh38-x73v](https://osv.dev/vulnerability/GHSA-3qjf-qh38-x73v)
- <https://github.com/miniflux/v2/security/advisories/GHSA-3qjf-qh38-x73v>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-27591>
- <https://github.com/miniflux/v2/pull/1745>
- <https://github.com/miniflux/v2>
- <https://github.com/miniflux/v2/releases/tag/2.0.43>
- <https://miniflux.app/docs/configuration.html#metrics-collector>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3qjf-qh38-x73v>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3qjf-qh38-x73v/>. Everything for agents: <https://agentprime.io/llms.txt>.
