# Apache Tomcat Denial of Service via invalid HTTP priority header

Advisory record · `GHSA-3p2h-wqq4-wf4h`

- **Identifiers:** `GHSA-3p2h-wqq4-wf4h` · `BIT-tomcat-2025-31650` · `CVE-2025-31650`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-459](https://cwe.mitre.org/data/definitions/459.html) · [CWE-460](https://cwe.mitre.org/data/definitions/460.html)
- **Tags:** [CWE-459](https://agentprime.io/advisories/tag/cwe-459.md) · [CWE-460](https://agentprime.io/advisories/tag/cwe-460.md)
- **Published:** 28 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Apr 2025, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 7.5 (7.0 or more) and EPSS 0.61 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.apache.tomcat:tomcat-coyote` (Maven): affected `>=9.0.76, <9.0.104 || >=10.1.10, <10.1.40 || >=11.0.0-M2, <11.0.6 || >=8.5.0, <=8.5.100`; fixed in `9.0.104`, `10.1.40`, `11.0.6`
- `org.apache.tomcat.embed:tomcat-embed-core` (Maven): affected `>=9.0.76, <9.0.104 || >=10.1.10, <10.1.40 || >=11.0.0-M2, <11.0.6 || >=8.5.0, <=8.5.100`; fixed in `9.0.104`, `10.1.40`, `11.0.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache Tomcat (tomcat-coyote and tomcat-embed-core packages) is affected in versions 9.0.76 through 9.0.102, 10.1.10 through 10.1.39, 11.0.0-M2 through 11.0.5, and 8.5.90 through 8.5.100. An attacker can send a large number of HTTP requests with invalid priority headers, which leaves failed requests incompletely cleaned up, causing a memory leak that can lead to an OutOfMemoryError and denial of service. Upgrade to Tomcat 9.0.104, 10.1.40, or 11.0.6.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.61, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:17 UTC: First seen by agentprime
- 31 Oct 2026, 14:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3p2h-wqq4-wf4h)

## Sources

- [GitHub Advisory Database: GHSA-3p2h-wqq4-wf4h](https://github.com/advisories/GHSA-3p2h-wqq4-wf4h)
- [OSV: GHSA-3p2h-wqq4-wf4h](https://osv.dev/vulnerability/GHSA-3p2h-wqq4-wf4h)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-31650>
- <https://github.com/apache/tomcat/commit/1eef1dc459c45f1e421d8bd25ef340fc1cc34edc>
- <https://github.com/apache/tomcat/commit/40ae788c2e64d018b4e58cd4210bb96434d0100d>
- <https://github.com/apache/tomcat/commit/75554da2fc5574862510ae6f0d7b3d78937f1d40>
- <https://github.com/apache/tomcat/commit/8cc3b8fb3f2d8d4d6a757e014f19d1fafa948a60>
- <https://github.com/apache/tomcat/commit/b7674782679e1514a0d154166b1d04d38aaac4a9>
- <https://github.com/apache/tomcat/commit/b98e74f517b36929f4208506e5adad22cb767baa>
- <https://github.com/apache/tomcat/commit/cba1a0fe1289ee7f5dd46c61c38d1e1ac5437bff>
- <https://github.com/apache/tomcat/commit/ded0285b96b4d3f5560dfc8856ad5ec4a9b50ba9>
- <https://github.com/apache/tomcat/commit/f619e6a05029538886d5a9d987925d573b5bb8c2>
- <https://github.com/apache/tomcat>
- <https://lists.apache.org/thread/j6zzk0y3yym9pzfzkq5vcyxzz0yzh826>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3p2h-wqq4-wf4h>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3p2h-wqq4-wf4h/>. Everything for agents: <https://agentprime.io/llms.txt>.
