# wlc may disclose API tokens to project-configured URLs

Advisory record · `GHSA-3mqq-hv9c-85hc`

- **Identifiers:** `GHSA-3mqq-hv9c-85hc` · `CVE-2026-62364` · `PYSEC-2026-4180`
- **State:** Confirmed
- **Severity:** CVSS 2.3 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-349](https://cwe.mitre.org/data/definitions/349.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-349](https://agentprime.io/advisories/tag/cwe-349.md)
- **Published:** 22 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Sept 2026, 20:34 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `wlc` (PyPI): affected `<2.0.1`; fixed in `2.0.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The wlc package before 2.0.1 may send an unscoped API token to a URL defined in project configuration when run in an untrusted directory tree, such as a pull request checkout. An attacker who controls that configuration can receive the user's token if the user supplies it through WLC_KEY or --key without also setting the URL. Upgrade to wlc 2.0.1 or newer, which requires WLC_URL or --url alongside an unscoped key; until then, always set the API URL explicitly when using an unscoped key.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.3 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0008, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3mqq-hv9c-85hc)

## Sources

- [GitHub Advisory Database: GHSA-3mqq-hv9c-85hc](https://github.com/advisories/GHSA-3mqq-hv9c-85hc)
- [OSV: GHSA-3mqq-hv9c-85hc](https://osv.dev/vulnerability/GHSA-3mqq-hv9c-85hc)
- <https://github.com/WeblateOrg/wlc/security/advisories/GHSA-3mqq-hv9c-85hc>
- <https://github.com/WeblateOrg/wlc/pull/1500>
- <https://github.com/WeblateOrg/wlc/commit/15cbdfc5b2c6183ef6864ea758091643a0ce6c89>
- <https://github.com/WeblateOrg/wlc>
- <https://github.com/WeblateOrg/wlc/releases/tag/2.0.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3mqq-hv9c-85hc>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3mqq-hv9c-85hc/>. Everything for agents: <https://agentprime.io/llms.txt>.
