# \[Eclipse Theia\] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat

Advisory record · `GHSA-3jww-hxqj-wfq2`

- **Identifiers:** `GHSA-3jww-hxqj-wfq2` · `CVE-2026-44688`
- **State:** Confirmed
- **Severity:** CVSS 8.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-829](https://cwe.mitre.org/data/definitions/829.html) · [CWE-1427](https://cwe.mitre.org/data/definitions/1427.html)
- **Tags:** [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md) · [CWE-1427](https://agentprime.io/advisories/tag/cwe-1427.md)
- **Published:** 18 Jun 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Jun 2026, 18:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@theia/ai-chat-ui` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-chat` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-claude-code` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-code-completion` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-core` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-editor` (npm): affected `<1.71.0`; fixed in `1.71.0`
- `@theia/ai-ide` (npm): affected `<1.71.0`; fixed in `1.71.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.4 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 18 Jun 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-3jww-hxqj-wfq2](https://github.com/advisories/GHSA-3jww-hxqj-wfq2)
- [OSV: GHSA-3jww-hxqj-wfq2](https://osv.dev/vulnerability/GHSA-3jww-hxqj-wfq2)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44688>
- <https://github.com/eclipse-theia/theia/issues/16892>
- <https://github.com/eclipse-theia/theia/pull/17364>
- <https://github.com/eclipse-theia/theia/commit/e3fdfe6992389bc5fa611058d00c39d7408508ed>
- <https://github.com/eclipse-theia/theia>
- <https://gitlab.eclipse.org/security/cve-assignment/-/work_items/113>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3jww-hxqj-wfq2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3jww-hxqj-wfq2/>. Everything for agents: <https://agentprime.io/llms.txt>.
