# JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)

Advisory record · `GHSA-3jqq-pw4j-pqcj`

- **Identifiers:** `GHSA-3jqq-pw4j-pqcj` · `CVE-2026-102830` · `PYSEC-2026-4056` · `PYSEC-2026-4059`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-625](https://cwe.mitre.org/data/definitions/625.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [CWE-625](https://agentprime.io/advisories/tag/cwe-625.md)
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Oct 2026, 15:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jupyterlab` (PyPI): affected `>=4.6.0, <4.6.4 || >=3.0.0, <4.5.11`; fixed in `4.6.4`, `4.5.11`
- `jupyterlite-core` (PyPI): affected `<0.8.4`; fixed in `0.8.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0026, the 17th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3jqq-pw4j-pqcj)

## Sources

- [GitHub Advisory Database: GHSA-3jqq-pw4j-pqcj](https://github.com/advisories/GHSA-3jqq-pw4j-pqcj)
- [OSV: GHSA-3jqq-pw4j-pqcj](https://osv.dev/vulnerability/GHSA-3jqq-pw4j-pqcj)
- <https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-3jqq-pw4j-pqcj>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102830>
- <https://github.com/jupyterlab/jupyterlab/commit/985a3223cd77fd4f991cd90066342a90711d70f6>
- <https://github.com/jupyterlab/jupyterlab/commit/de324ae91346c713c4f5e5485f97b6e914e0f774>
- <https://github.com/jupyterlab/jupyterlab/commit/f9de43dc565a1118120d466117f877a189a4ce90>
- <https://github.com/jupyterlab/jupyterlab>
- <https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11>
- <https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3jqq-pw4j-pqcj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3jqq-pw4j-pqcj/>. Everything for agents: <https://agentprime.io/llms.txt>.
