# veraPDF Validation XXE via Rich Text

Advisory record · `GHSA-3jh7-wm29-q568`

- **Identifiers:** `GHSA-3jh7-wm29-q568` · `CVE-2026-54078`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-611](https://cwe.mitre.org/data/definitions/611.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md)
- **Published:** 29 Jul 2026
- **Updated:** 29 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Jul 2026, 15:11 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.verapdf:validation-model` (Maven): affected `>=1.25.73, <1.30.2 || >=1.31.1, <1.31.71`; fixed in `1.30.2`, `1.31.71`
- `org.verapdf:validation-model-jakarta` (Maven): affected `>=1.25.73, <1.30.2 || >=1.31.1, <1.31.71`; fixed in `1.30.2`, `1.31.71`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> veraPDF validation-model and validation-model-jakarta (Maven) versions from 1.25.73 up to 1.30.2 and from 1.31.1 up to 1.31.71 are affected by an XML External Entity Injection vulnerability in rich-text (/RC or /RV) handling. A remote attacker who gets the target to validate a crafted PDF can read arbitrary files on the server and perform server-side request forgery. Upgrade to version 1.30.2 or 1.31.71, which are the listed fixed versions.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0056, the 46th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:19 UTC: First seen by agentprime
- 31 Oct 2026, 14:19 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3jh7-wm29-q568)

## Sources

- [GitHub Advisory Database: GHSA-3jh7-wm29-q568](https://github.com/advisories/GHSA-3jh7-wm29-q568)
- [OSV: GHSA-3jh7-wm29-q568](https://osv.dev/vulnerability/GHSA-3jh7-wm29-q568)
- <https://github.com/veraPDF/veraPDF-validation/security/advisories/GHSA-3jh7-wm29-q568>
- <https://github.com/veraPDF/veraPDF-validation>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3jh7-wm29-q568>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3jh7-wm29-q568/>. Everything for agents: <https://agentprime.io/llms.txt>.
