# thorsten/phpmyfaq vulnerable to stored cross-site scripting (XSS) in FAQ comment username parameter

Advisory record · `GHSA-3j93-7rf7-p7m6`

- **Identifiers:** `GHSA-3j93-7rf7-p7m6` · `CVE-2023-1758` · `PKSA-5jvn-xj5h-yxw7`
- **State:** Confirmed
- **Severity:** CVSS 8.9 High
- **Critical:** No
- **Weakness (CWE):** [CWE-75](https://cwe.mitre.org/data/definitions/75.html) · [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-75](https://agentprime.io/advisories/tag/cwe-75.md)
- **Published:** 5 Apr 2023
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Apr 2023, 18:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `thorsten/phpmyfaq` (Packagist): affected `<3.1.12`; fixed in `3.1.12`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.9 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 5 Apr 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-3j93-7rf7-p7m6](https://github.com/advisories/GHSA-3j93-7rf7-p7m6)
- [OSV: GHSA-3j93-7rf7-p7m6](https://osv.dev/vulnerability/GHSA-3j93-7rf7-p7m6)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-1758>
- <https://github.com/thorsten/phpmyfaq/commit/f3380f46c464d1bc6f3ded29213c79be0de8fc57>
- <https://github.com/thorsten/phpMyFAQ>
- <https://huntr.dev/bounties/0854328e-eb00-41a3-9573-8da8f00e369c>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3j93-7rf7-p7m6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3j93-7rf7-p7m6/>. Everything for agents: <https://agentprime.io/llms.txt>.
