# Gotify: Insufficiently Protected Password Change endpoint

Advisory record · `GHSA-3hcj-9m7p-wwm9`

- **Identifiers:** `GHSA-3hcj-9m7p-wwm9` · `CVE-2026-102603` · `GO-2026-6772`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-620](https://cwe.mitre.org/data/definitions/620.html)
- **Tags:** [CWE-620](https://agentprime.io/advisories/tag/cwe-620.md)
- **Published:** 15 Oct 2026
- **Updated:** 19 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Oct 2026, 20:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/gotify/server/v2` (Go): affected `<=2.9.1`; no fixed version yet
- `github.com/gotify/server/v3` (Go): affected `<3.0.0`; fixed in `3.0.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Gotify server versions 2.9.1 and earlier (github.com/gotify/server/v2) and versions before 3.0.0 (github.com/gotify/server/v3) let the password change endpoint run without the current password. An attacker holding a valid client token can set a new password for the affected user, and recovery requires an administrator or direct database access. Upgrade the v3 module to 3.0.0, which requires re-authentication to change a password; no fixed version is listed for v2.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3hcj-9m7p-wwm9)

## Sources

- [GitHub Advisory Database: GHSA-3hcj-9m7p-wwm9](https://github.com/advisories/GHSA-3hcj-9m7p-wwm9)
- [OSV: GHSA-3hcj-9m7p-wwm9](https://osv.dev/vulnerability/GHSA-3hcj-9m7p-wwm9)
- <https://github.com/gotify/server/security/advisories/GHSA-3hcj-9m7p-wwm9>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102603>
- <https://github.com/gotify/server/pull/952>
- <https://github.com/gotify/server/commit/a8744482c668e07a61798573ec8e17bd3f6009f9>
- <https://github.com/gotify/server>
- <https://github.com/gotify/server/releases/tag/v3.0.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3hcj-9m7p-wwm9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3hcj-9m7p-wwm9/>. Everything for agents: <https://agentprime.io/llms.txt>.
