# Jetty vulnerable to errant command quoting in CGI Servlet

Advisory record · `GHSA-3gh6-v5v9-6v9j`

- **Identifiers:** `GHSA-3gh6-v5v9-6v9j` · `CVE-2023-36479`
- **State:** Confirmed
- **Severity:** CVSS 3.5 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-149](https://cwe.mitre.org/data/definitions/149.html)
- **Tags:** [CWE-149](https://agentprime.io/advisories/tag/cwe-149.md)
- **Published:** 14 Sept 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Sept 2023, 16:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.eclipse.jetty:jetty-servlets` (Maven): affected `>=9.0.0, <9.4.52 || >=10.0.0, <10.0.16 || >=11.0.0, <11.0.16`; fixed in `9.4.52`, `10.0.16`, `11.0.16`
- `org.eclipse.jetty.ee10:jetty-ee10-servlets` (Maven): affected `<12.0.0-beta2`; fixed in `12.0.0-beta2`
- `org.eclipse.jetty.ee9:jetty-ee9-servlets` (Maven): affected `<12.0.0-beta2`; fixed in `12.0.0-beta2`
- `org.eclipse.jetty.ee8:jetty-ee8-servlets` (Maven): affected `<12.0.0-beta2`; fixed in `12.0.0-beta2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.5 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3gh6-v5v9-6v9j)

## Sources

- [GitHub Advisory Database: GHSA-3gh6-v5v9-6v9j](https://github.com/advisories/GHSA-3gh6-v5v9-6v9j)
- [OSV: GHSA-3gh6-v5v9-6v9j](https://osv.dev/vulnerability/GHSA-3gh6-v5v9-6v9j)
- <https://github.com/eclipse/jetty.project/security/advisories/GHSA-3gh6-v5v9-6v9j>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-36479>
- <https://github.com/eclipse/jetty.project/pull/9516>
- <https://github.com/eclipse/jetty.project/pull/9888>
- <https://github.com/eclipse/jetty.project/pull/9889>
- <https://github.com/eclipse/jetty.project>
- <https://lists.debian.org/debian-lts-announce/2023/09/msg00039.html>
- <https://www.debian.org/security/2023/dsa-5507>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3gh6-v5v9-6v9j>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3gh6-v5v9-6v9j/>. Everything for agents: <https://agentprime.io/llms.txt>.
