# Canonical LXD Vulnerable to Privilege Escalation via WebSocket Connection Hijacking in Operations API

Advisory record · `GHSA-3g72-chj4-2228`

- **Identifiers:** `GHSA-3g72-chj4-2228` · `CVE-2025-54289` · `GO-2025-3999`
- **State:** Confirmed
- **Severity:** CVSS 7.4 High
- **Critical:** No
- **Weakness (CWE):** [CWE-1385](https://cwe.mitre.org/data/definitions/1385.html)
- **Tags:** [CWE-1385](https://agentprime.io/advisories/tag/cwe-1385.md)
- **Published:** 2 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 2 Oct 2025, 21:19 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/canonical/lxd` (Go): affected `>=4.0, <5.21.4 || >=6.0, <6.5 || >=0.0.0-20200331193331-03aab09f5b5c, <0.0.0-20250827065555-0494f5d47e41`; fixed in `5.21.4`, `6.5`, `0.0.0-20250827065555-0494f5d47e41`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Canonical LXD versions from 4.0 before 5.21.4 and from 6.0 before 6.5, along with certain earlier Go module pseudo-versions, are vulnerable. An attacker with only read permission on a project can obtain WebSocket secrets from the operations API and use them to hijack another user's terminal or console session, running commands with that user's privileges; the attack depends on timing. Upgrade to LXD 5.21.4, 6.5, or the fixed pseudo-version 0.0.0-20250827065555-0494f5d47e41.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.4 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`, from CNA (canonical)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0021, the 11th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3g72-chj4-2228)

## Sources

- [GitHub Advisory Database: GHSA-3g72-chj4-2228](https://github.com/advisories/GHSA-3g72-chj4-2228)
- [OSV: GHSA-3g72-chj4-2228](https://osv.dev/vulnerability/GHSA-3g72-chj4-2228)
- <https://github.com/canonical/lxd/security/advisories/GHSA-3g72-chj4-2228>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-54289>
- <https://github.com/canonical/lxd>
- <https://pkg.go.dev/vuln/GO-2025-3999>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3g72-chj4-2228>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3g72-chj4-2228/>. Everything for agents: <https://agentprime.io/llms.txt>.
