# Peer minimum ACK delay can panic quinn-proto when ACK_FREQUENCY transmission is enabled

Advisory record · `GHSA-3g6h-r5qx-f6hq`

- **Identifiers:** `GHSA-3g6h-r5qx-f6hq` · `RUSTSEC-2026-0340`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Published:** 14 Sept 2026
- **Updated:** 12 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Sept 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `quinn-proto` (crates.io): affected `>=0.11.0, <0.11.18`; fixed in `0.11.18`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Peer-supplied transport parameters can make quinn-proto panic: versions 0.11.0 up to but not including 0.11.18 of the quinn-proto crate are affected when sending ACK_FREQUENCY frames is enabled through the transport configuration. A remote peer that advertises a minimum ACK delay greater than its maximum ACK delay can trigger a panic while the connection is being driven, which crashes the process. Sending ACK_FREQUENCY frames is disabled by default, so only endpoints that opt in are affected. Upgrade quinn-proto to version 0.11.18 or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0340)

## Sources

- [GitHub Advisory Database: GHSA-3g6h-r5qx-f6hq](https://github.com/advisories/GHSA-3g6h-r5qx-f6hq)
- [OSV: GHSA-3g6h-r5qx-f6hq](https://osv.dev/vulnerability/GHSA-3g6h-r5qx-f6hq)
- <https://crates.io/crates/quinn-proto>
- <https://rustsec.org/advisories/RUSTSEC-2026-0340.html>
- <https://github.com/quinn-rs/quinn/pull/2868>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3g6h-r5qx-f6hq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3g6h-r5qx-f6hq/>. Everything for agents: <https://agentprime.io/llms.txt>.
