# Mattermost Playbooks fails to properly validate the props used by the RetrospectivePost custom post type

Advisory record · `GHSA-3g36-gf7c-75qw`

- **Identifiers:** `GHSA-3g36-gf7c-75qw` · `CVE-2025-41395` · `GO-2025-3642`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 24 Apr 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Apr 2025, 09:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/mattermost/mattermost-plugin-playbooks` (Go): affected `>=2.0.0 || <1.41.0`; fixed in `1.41.0`
- `github.com/mattermost/mattermost/server/v8` (Go): affected `<8.0.0-20250218121836-2b5275d87136 || >=10.4.0 || >=10.5.0 || >=9.11.0`; fixed in `8.0.0-20250218121836-2b5275d87136`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mattermost Playbooks plugin (github.com/mattermost/mattermost-plugin-playbooks) versions before 1.41.0 and 2.0.0 and later are affected, and the Mattermost server (github.com/mattermost/mattermost/server/v8) is affected in several version ranges. An attacker who can create posts can craft a RetrospectivePost post with malicious props, causing a denial of service of the web app for all users. Upgrade the Playbooks plugin to 1.41.0 or the server to 8.0.0-20250218121836-2b5275d87136.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (Mattermost)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0050, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3g36-gf7c-75qw)

## Sources

- [GitHub Advisory Database: GHSA-3g36-gf7c-75qw](https://github.com/advisories/GHSA-3g36-gf7c-75qw)
- [OSV: GHSA-3g36-gf7c-75qw](https://osv.dev/vulnerability/GHSA-3g36-gf7c-75qw)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-41395>
- <https://github.com/mattermost/mattermost-plugin-playbooks/commit/4c823090e281cb9c0d5c17ee2e5db275117540d1>
- <https://github.com/mattermost/mattermost/commit/2b5275d87136f07e016c8eca09a2f004b31afc8a>
- <https://github.com/mattermost/mattermost-plugin-playbooks>
- <https://mattermost.com/security-updates>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3g36-gf7c-75qw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3g36-gf7c-75qw/>. Everything for agents: <https://agentprime.io/llms.txt>.
