# Decidim's private data exports can lead to data leaks

Advisory record · `GHSA-3cx6-j9j4-54mp`

- **Identifiers:** `GHSA-3cx6-j9j4-54mp` · `CVE-2025-65017`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-703](https://cwe.mitre.org/data/definitions/703.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-703](https://agentprime.io/advisories/tag/cwe-703.md)
- **Published:** 3 Feb 2026
- **Updated:** 8 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Feb 2026, 17:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `decidim-core` (RubyGems): affected `>=0.30.0, <0.30.4`; fixed in `0.30.4`
- `decidim` (RubyGems): affected `>=0.30.0, <0.30.4`; fixed in `0.30.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0031, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 3 Feb 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-3cx6-j9j4-54mp](https://github.com/advisories/GHSA-3cx6-j9j4-54mp)
- [OSV: GHSA-3cx6-j9j4-54mp](https://osv.dev/vulnerability/GHSA-3cx6-j9j4-54mp)
- <https://github.com/decidim/decidim/security/advisories/GHSA-3cx6-j9j4-54mp>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-65017>
- <https://github.com/decidim/decidim/pull/13571>
- <https://github.com/decidim/decidim>
- <https://github.com/decidim/decidim/releases/tag/v0.30.4>
- <https://github.com/decidim/decidim/releases/tag/v0.31.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim-core/CVE-2025-65017.yml>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/decidim/CVE-2025-65017.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3cx6-j9j4-54mp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3cx6-j9j4-54mp/>. Everything for agents: <https://agentprime.io/llms.txt>.
