# yt-dlp Generic Extractor MITM Vulnerability via Arbitrary Proxy Injection

Advisory record · `GHSA-3ch3-jhc6-5r8x`

- **Identifiers:** `GHSA-3ch3-jhc6-5r8x` · `CVE-2023-46121` · `PYSEC-2026-2063`
- **State:** Confirmed
- **Severity:** CVSS 5.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html) · [CWE-613](https://cwe.mitre.org/data/definitions/613.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md) · [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md)
- **Published:** 15 Nov 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Nov 2023, 14:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yt-dlp` (PyPI): affected `>=2022.10.04, <2023.11.14`; fixed in `2023.11.14`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> yt-dlp versions from 2022.10.04 before 2023.11.14 are affected. A malicious website can use the Generic extractor to set an arbitrary proxy for requests yt-dlp makes, allowing a man-in-the-middle attack that may expose cookies not marked secure. Upgrade to yt-dlp 2023.11.14 or later; as a workaround, disable the Generic extractor with --ies default,-generic.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.0 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0032, the 25th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:36 UTC: First seen by agentprime
- 31 Oct 2026, 14:36 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3ch3-jhc6-5r8x)

## Sources

- [GitHub Advisory Database: GHSA-3ch3-jhc6-5r8x](https://github.com/advisories/GHSA-3ch3-jhc6-5r8x)
- [OSV: GHSA-3ch3-jhc6-5r8x](https://osv.dev/vulnerability/GHSA-3ch3-jhc6-5r8x)
- <https://github.com/yt-dlp/yt-dlp/security/advisories/GHSA-3ch3-jhc6-5r8x>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-46121>
- <https://github.com/yt-dlp/yt-dlp/commit/f04b5bedad7b281bee9814686bba1762bae092eb>
- <https://github.com/yt-dlp/yt-dlp>
- <https://github.com/yt-dlp/yt-dlp/releases/tag/2023.11.14>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3ch3-jhc6-5r8x>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3ch3-jhc6-5r8x/>. Everything for agents: <https://agentprime.io/llms.txt>.
