# Excalidraw vulnerable to XSS via Mermaid sequence diagram labels (KaTeX rendering)

Advisory record · `GHSA-39h7-pwv7-rc3x`

- **Identifiers:** `GHSA-39h7-pwv7-rc3x`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 24 Apr 2026
- **Updated:** 5 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Apr 2026, 20:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@excalidraw/excalidraw` (npm): affected `>=0.18.0, <0.18.1`; fixed in `0.18.1`
- `@excalidraw/mermaid-to-excalidraw` (npm): affected `>=0.3.0, <1.1.3`; fixed in `1.1.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 24 Apr 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-39h7-pwv7-rc3x](https://github.com/advisories/GHSA-39h7-pwv7-rc3x)
- [OSV: GHSA-39h7-pwv7-rc3x](https://osv.dev/vulnerability/GHSA-39h7-pwv7-rc3x)
- <https://github.com/excalidraw/excalidraw/security/advisories/GHSA-39h7-pwv7-rc3x>
- <https://github.com/mermaid-js/mermaid/security/advisories/GHSA-7rqq-prvp-x9jh>
- <https://github.com/excalidraw/excalidraw>
- <https://github.com/excalidraw/excalidraw/releases/tag/v0.18.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-39h7-pwv7-rc3x>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-39h7-pwv7-rc3x/>. Everything for agents: <https://agentprime.io/llms.txt>.
