# go-git's improper parsing of specially crafted objects may lead to inconsistent interpretation compared to upstream Git

Advisory record · `GHSA-389r-gv7p-r3rp`

- **Identifiers:** `GHSA-389r-gv7p-r3rp` · `CVE-2026-45022` · `GO-2026-5074`
- **State:** Confirmed
- **Severity:** CVSS 7.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-180](https://cwe.mitre.org/data/definitions/180.html) · [CWE-345](https://cwe.mitre.org/data/definitions/345.html)
- **Tags:** [CWE-180](https://agentprime.io/advisories/tag/cwe-180.md) · [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md)
- **Published:** 11 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 May 2026, 14:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/go-git/go-git/v6` (Go): affected `>=6.0.0-alpha.1, <6.0.0-alpha.3`; fixed in `6.0.0-alpha.3`
- `github.com/go-git/go-git/v5` (Go): affected `<5.19.0`; fixed in `5.19.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Two go-git modules are affected. The v6 module github.com/go-git/go-git/v6 is vulnerable from 6.0.0-alpha.1 before 6.0.0-alpha.3, and the v5 module github.com/go-git/go-git/v5 is vulnerable before 5.19.0. An attacker who can supply malformed commit or tag objects can cause go-git to parse them differently than upstream Git, and commit signing and verification run over reconstructed data, so a signature may appear valid for a commit whose metadata differs from the signed object. Upgrade v6 to 6.0.0-alpha.3 or v5 to 5.19.0. The source gives few details on the exact attack conditions.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.0 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0016, the 5th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:13 UTC: First seen by agentprime
- 31 Oct 2026, 14:13 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-389r-gv7p-r3rp)

## Sources

- [GitHub Advisory Database: GHSA-389r-gv7p-r3rp](https://github.com/advisories/GHSA-389r-gv7p-r3rp)
- [OSV: GHSA-389r-gv7p-r3rp](https://osv.dev/vulnerability/GHSA-389r-gv7p-r3rp)
- <https://github.com/go-git/go-git/security/advisories/GHSA-389r-gv7p-r3rp>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-45022>
- <https://github.com/go-git/go-git>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-389r-gv7p-r3rp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-389r-gv7p-r3rp/>. Everything for agents: <https://agentprime.io/llms.txt>.
