# JupyterLab has an Extension Manager API/GUI Policy Discrepancy, allowing 3rd party (malicious) extensions install via POST request

Advisory record · `GHSA-37w4-hwhx-4rc4`

- **Identifiers:** `GHSA-37w4-hwhx-4rc4` · `BIT-jupyterlab-2026-42266` · `CVE-2026-42266` · `PYSEC-2026-164`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-88](https://cwe.mitre.org/data/definitions/88.html) · [CWE-602](https://cwe.mitre.org/data/definitions/602.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-602](https://agentprime.io/advisories/tag/cwe-602.md)
- **Published:** 5 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2026, 20:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jupyterlab` (PyPI): affected `>=4.0.0, <4.5.7`; fixed in `4.5.7`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.057, the 92nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-37w4-hwhx-4rc4)

## Sources

- [GitHub Advisory Database: GHSA-37w4-hwhx-4rc4](https://github.com/advisories/GHSA-37w4-hwhx-4rc4)
- [OSV: GHSA-37w4-hwhx-4rc4](https://osv.dev/vulnerability/GHSA-37w4-hwhx-4rc4)
- <https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42266>
- <https://github.com/jupyterlab/jupyterlab>
- <https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7>
- <https://github.com/pypa/advisory-database/tree/main/vulns/jupyterlab/PYSEC-2026-164.yaml>
- <https://jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html>
- <https://jupyterlab.readthedocs.io/en/latest/user/extensions.html#extension-manager-implementations>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-37w4-hwhx-4rc4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-37w4-hwhx-4rc4/>. Everything for agents: <https://agentprime.io/llms.txt>.
