# Pydantic AI Harness tool-call limit bypass in nested CodeMode calls

Advisory record · `GHSA-3589-pxp7-3gj8`

- **Identifiers:** `GHSA-3589-pxp7-3gj8` · `CVE-2026-114386`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Oct 2026, 15:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pydantic-ai-harness` (PyPI): affected `<0.59.0`; fixed in `0.59.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Pydantic AI Harness (pydantic-ai-harness) versions before 0.59.0 do not enforce the tool-call limit on tools invoked from within run_code in the CodeMode toolset. An attacker who can influence the sandboxed program, including through prompt-injected content, can call tools past the operator's limit, including costly or side-effecting ones. Upgrade to pydantic-ai-harness 0.59.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:08 UTC: First seen by agentprime
- 31 Oct 2026, 14:08 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3589-pxp7-3gj8)

## Sources

- [GitHub Advisory Database: GHSA-3589-pxp7-3gj8](https://github.com/advisories/GHSA-3589-pxp7-3gj8)
- [OSV: GHSA-3589-pxp7-3gj8](https://osv.dev/vulnerability/GHSA-3589-pxp7-3gj8)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-114386>
- <https://github.com/pydantic/pydantic-ai/pull/10362>
- <https://github.com/pydantic/pydantic-ai/commit/eb27b2b89fe76ae23ee9b6fc9eb4b227a4967949>
- <https://github.com/pydantic/pydantic-ai>
- <https://github.com/pydantic/pydantic-ai/blob/v2.58.0/src/pydantic_ai_harness/pydantic_ai_harness/code_mode/_toolset.py#L642-L680>
- <https://github.com/pydantic/pydantic-ai/releases/tag/v2.59.0>
- <https://pypi.org/project/pydantic-ai-harness/0.59.0>
- <https://www.vulncheck.com/advisories/pydantic-ai-harness-before-0.59.0-codemode-tool-call-limit-bypass-via-run-code>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3589-pxp7-3gj8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3589-pxp7-3gj8/>. Everything for agents: <https://agentprime.io/llms.txt>.
