# Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)

Advisory record · `GHSA-353f-5xf4-qw67`

- **Identifiers:** `GHSA-353f-5xf4-qw67` · `CVE-2023-34092`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-50](https://cwe.mitre.org/data/definitions/50.html) · [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-706](https://cwe.mitre.org/data/definitions/706.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-50](https://agentprime.io/advisories/tag/cwe-50.md) · [CWE-706](https://agentprime.io/advisories/tag/cwe-706.md)
- **Published:** 6 Jun 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Jun 2023, 02:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vite` (npm): affected `<2.9.16 || >=3.0.2, <3.2.7 || >=4.0.0, <4.0.5 || >=4.1.0, <4.1.5 || >=4.2.0, <4.2.3 || >=4.3.0, <4.3.9`; fixed in `2.9.16`, `3.2.7`, `4.0.5`, `4.1.5`, `4.2.3`, `4.3.9`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.032, the 87th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 6 Jun 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-353f-5xf4-qw67](https://github.com/advisories/GHSA-353f-5xf4-qw67)
- [OSV: GHSA-353f-5xf4-qw67](https://osv.dev/vulnerability/GHSA-353f-5xf4-qw67)
- <https://github.com/vitejs/vite/security/advisories/GHSA-353f-5xf4-qw67>
- <https://nvd.nist.gov/vuln/detail/CVE-2023-34092>
- <https://github.com/vitejs/vite/pull/13348>
- <https://github.com/vitejs/vite/commit/813ddd6155c3d54801e264ba832d8347f6f66b32>
- <https://github.com/vitejs/vite>
- <https://security.snyk.io/package/npm/vite/3.2.0-beta.4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-353f-5xf4-qw67>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-353f-5xf4-qw67/>. Everything for agents: <https://agentprime.io/llms.txt>.
