# vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inferenc...

Advisory record · `GHSA-34qw-q2h2-jp3m`

- **Identifiers:** `GHSA-34qw-q2h2-jp3m` · `CVE-2026-116178` · `PYSEC-2026-4353`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 25 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 25 Oct 2026, 14:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.20.0, <0.30.0`; fixed in `0.30.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions from 0.20.0 before 0.30.0 are affected by a denial of service flaw in the disaggregated /inference/v1/generate endpoint. A remote attacker can send inconsistent multimodal metadata, such as repeated or overlapping placeholder ranges or mismatched kwargs and hash lists, which produces a negative text span in Qwen2.5-VL position construction and crashes the engine. Upgrade vLLM to version 0.30.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 26th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-4353)

## Sources

- [GitHub Advisory Database: GHSA-34qw-q2h2-jp3m](https://github.com/advisories/GHSA-34qw-q2h2-jp3m)
- [OSV: GHSA-34qw-q2h2-jp3m](https://osv.dev/vulnerability/GHSA-34qw-q2h2-jp3m)
- <https://www.vulncheck.com/advisories/vllm-0.20.0-before-0.30.0-dos-via-inference-v1-generate-mm-placeholders>
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-34qw-q2h2-jp3m>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-34qw-q2h2-jp3m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-34qw-q2h2-jp3m/>. Everything for agents: <https://agentprime.io/llms.txt>.
