# Stack overflow on deeply nested GraphQL documents

Advisory record · `GHSA-34cw-x8g7-rcv5`

- **Identifiers:** `GHSA-34cw-x8g7-rcv5` · `RUSTSEC-2026-0416`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `juniper` (crates.io): affected `>=0.0.0-0, <0.17.2`; fixed in `0.17.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Juniper versions before 0.17.2 are vulnerable to a stack overflow when parsing, validating, or executing deeply nested GraphQL documents, such as deeply nested selection sets or long chains of fragment spreads. An unauthenticated attacker can send one such request to crash the whole process, which drops all other requests in progress. Upgrade to juniper 0.17.2, which limits nesting depth to 64 levels and document size to 15,000 tokens by default.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0416)

## Sources

- [GitHub Advisory Database: GHSA-34cw-x8g7-rcv5](https://github.com/advisories/GHSA-34cw-x8g7-rcv5)
- [OSV: GHSA-34cw-x8g7-rcv5](https://osv.dev/vulnerability/GHSA-34cw-x8g7-rcv5)
- <https://crates.io/crates/juniper>
- <https://rustsec.org/advisories/RUSTSEC-2026-0416.html>
- <https://github.com/graphql-rust/juniper/pull/1405>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-34cw-x8g7-rcv5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-34cw-x8g7-rcv5/>. Everything for agents: <https://agentprime.io/llms.txt>.
