# Mattermost allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences

Advisory record · `GHSA-3439-vqgj-2gcf`

- **Identifiers:** `GHSA-3439-vqgj-2gcf` · `CVE-2026-3108` · `GO-2026-5067`
- **State:** Confirmed
- **Severity:** CVSS 8.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 26 Mar 2026
- **Updated:** 25 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Mar 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/mattermost/mattermost/server/v8` (Go): affected `>=11.4.0-rc1, <11.4.1 || >=11.3.0-rc1, <11.3.2 || >=11.2.0-rc1, <11.2.3 || >=10.11.0-rc1, <10.11.11 || >=8.0.0-20260105080200-d27a2195068d, <8.0.0-20260217110922-b7d4a1f1f59b`; fixed in `11.4.1`, `11.3.2`, `11.2.3`, `10.11.11`, `8.0.0-20260217110922-b7d4a1f1f59b`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.0 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`, from CNA (Mattermost)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0028, the 20th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:07 UTC: First seen by agentprime
- 31 Oct 2026, 15:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-3439-vqgj-2gcf)

## Sources

- [GitHub Advisory Database: GHSA-3439-vqgj-2gcf](https://github.com/advisories/GHSA-3439-vqgj-2gcf)
- [OSV: GHSA-3439-vqgj-2gcf](https://osv.dev/vulnerability/GHSA-3439-vqgj-2gcf)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-3108>
- <https://github.com/mattermost/mattermost>
- <https://mattermost.com/security-updates>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-3439-vqgj-2gcf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-3439-vqgj-2gcf/>. Everything for agents: <https://agentprime.io/llms.txt>.
